MediaTek Flashing Guide

Discussion in 'MTK' started by VirusPlus, Jun 21, 2014.

Remove Advertisements
  1. VirusPlus

    VirusPlus Staff Member Moderator Member

    Posts:
    356
    Likes Received:
    159
    Trophy Points:
    67
    Location:
    Athens, Greece
    Tablet:
    PiPO M9Pro, Chuwi V88
    Phone:
    Huawei Honor 6, Newman N2
    1. Download "MTK Drivers.zip", unzip and run "install_driver.exe".
    2. Download "SP_Flash_Tool_v5.1352.01.zip", unzip and run "flash_tool.exe".
    3. Click "Scatter-loading" button to load the correct scatter file (MTxxxx_Android_scatter_emmc.txt) for your device.
    4. Choose "Download Only" (or "Firmware Upgrade" in case of brick device) from drop-down menu and press "Download" button.
    5. Turn off your device and connect it into the computer.
    6. The process will start.
     

    Attached Files:

    stormrider and cyberlucio like this.
  2. DanLcc

    DanLcc Member

    Posts:
    1
    Likes Received:
    1
    Trophy Points:
    0
    Tablet:
    K960
    I am new to tablets and I have a chinese no name (actually it says K960) using a MediaTek mt8756. It worked fine for a while then one morning it would not boot and would not charge. Nothing on the screen when power button pressed or when charger was connected. I opened it and the battery voltage seems fine. I tried a few fixes I found on line but nothing worked. So I download the files recommended in this posting and installed them. Using Flash Tool I get to the button that says load scatter file and there are no scatter files contained in any of the downloads. I have been unable to find "MT8756_Android_scatter_emmc.txt" or anything close to that on the web. Do you have any helpful advice?

    Igoring the above, with Flash Tool running. I connected my tablet (power off) to my windows 7 pc by USB and the program did not respond in any way. I pushed power one and still no recoginition in Flash Tool. I have another identical tablet still working fine and tried the above with the working tablet. Same result, no recognition by Flash Tool. I pushed the power on button and the PC recognized the tablet but Flash Tools did not.

    There is more to the story. I have 3 of these identical tablets. The first one worked fine for a day and I put it on the charger over night. The next morning it was dead. I ordered another one. It worked fine. I was using it in bed and fell asleep and rolled over on it and broke the screen. I ordered another one it has been working fine for a couple of months. However, I would like to get the first one running again. The one with the broken screen should be good for spare parts but I don't think this is a hardware problem. I pretty good at PC repair and have done some very delicate notebook repair, so I have no hesitation to tear into the guts of these tablets. However, I think this problem could easily be fixed with software...if I just had all the information necessary.

    Any advice would be greatly appreciated.

    DanLcc
     
    mohamed tetouan likes this.
Remove Advertisements