W718J "Back" and "Home" buttons not working

Discussion in 'W718J' started by doggyfreestart, Nov 27, 2013.

Remove Advertisements
  1. doggyfreestart

    doggyfreestart Member

    Posts:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Phone:
    Lenovo A660
    I have a problem with my brand new (1 week usage) W718J. The "BACK" button doesn't work at all, and the "HOME" button has the same action as the left "MENU" softkey.
    I have tried to clean the area, but it's clean. Factory reset & wipe cache doesn't have any effect. I'm pretty much sure it's a hardware issue. Did anyone have the same effect?
     
  2. doggyfreestart

    doggyfreestart Member

    Posts:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Phone:
    Lenovo A660
    So it is a unique problem with my mobile phone... I'll have to send it back to Pandawill.
     
  3. Jaime4101

    Jaime4101 Member

    Posts:
    1
    Likes Received:
    0
    Trophy Points:
    0
    I have the same problem. Did they pay the return shipping cost? Thanks
     
  4. doggyfreestart

    doggyfreestart Member

    Posts:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Phone:
    Lenovo A660
    No, they didn't refund since the phone was already used. However, it was only 18 EURs from Germany.
     
  5. CooliCool

    CooliCool Local warehouse in Europe, 72 hours delivery! Verified Store Member

    Posts:
    953
    Likes Received:
    6
    Trophy Points:
    67
    Tablet:
    U30GT2
    Phone:
    STAR S9500
    TV Stick:
    MK802
    it is a hardware problem.
     
  6. doggyfreestart

    doggyfreestart Member

    Posts:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Phone:
    Lenovo A660
    And how often do you experience this particular problem in the field? I think it must be a manufacturing problem.
     
  7. mixer84

    mixer84 Member

    Posts:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Phone:
    Haier W718
    I have also the same problem, but in my case phone was working 4 moths fine. In the last days i have this issue.
     
Remove Advertisements