MK809ii noob, Bricked. Please help

Discussion in 'MK809' started by BikerBudgie, Feb 14, 2015.

Remove Advertisements
  1. BikerBudgie

    BikerBudgie Member

    Likes Received:
    Trophy Points:
    Samsung Tab3
    Samsung S5
    TV Stick:
    MK809, MK809ii, MK809iv
    Please help. Here is what I have done.

    I have an mk809ii, I wish to run an app call ARunchained on it, this requires the device to be rooted. I have rooted a couple of phone in the past so figured how hard can it be?

    I followed this youtube vid,
    (a vid of this guide - )

    And went as far as rooting the device, I rebooted the device and ran SuperSu. But I then had a message that the Binaries were not installed... I tried removing SuperSu but it only allowed me to remove updates, then rebooted and reinstalled them - same error.

    So a flash of inspiration! why not follow the rest of the youtube guide and install the finless Rom 1.7? my thoughts were a new ROM would over-write and give me a fresh install?

    Again following the YouTube guide I used the Finless ROM flash tool, each step went fine until 'Flash ROM' then I received 2 errors :- (screenshot attached)

    Error: Download IDB failed
    ERROR:Run failed

    and I now have no idea what to do? rebooting all devices makes no difference and the stick, with power LED on does not show up on the TV, no boot, nothing, zero.

    Please help :)

    Attached Files:

Remove Advertisements